iPhone Concerns?

The Ten Conditions of Bai'at application was built for the Apple iPhone OS. That means if you have an iPhone or an iPod that has at least the 2.0 software, the application should work perfectly fine for you! If you do not have the 2.0 software, but the original iPhone OS this application may not work the way it was intended.

Concerns about Other Phones?

Even though the The Ten Conditions of Bai'at application was built for the Apple iPhone, it is still viewable in other phones. In order to be able to view the application in the way it was intended, you will need a mobile browser that supports robust Javascript, CSS3, and HTML5. Phones that support this application are currently only limited to Android platform phones and the Palm Pre. If you are using a Windows Mobile or a Nokia device, you may download the third party browser, Skyfire, and view the application in it.